Ich habe folgendes Problem bei dem Zugriffspfad MYSQL Server des Bausteins DLOG_Store_MYSQL. Wenn ich da den SQL Server im String als login-xxx.hoststar.yy angebe, bekomme ich immer folgenden Error: Error_C= 65280 und Error_t = 1.
Das sollte DNS_Client Störung sein. Wenn ich die IP Adresse angebe, kann ich wie gewünscht auf dem SQL Server schreiben… .
Alternative:
Wenn ich den Baustein DNS_Client und dann IP4_to_String funktioniert die Umwandung vom Name in die IP perfekt.
Nun zur meine Frage:
Was macht der Baustein mit der Zugriffspfad MYSQL Server noch alles damit ich diesen Fehler bekommen und wie krig ich das gelöst? Alternative den URL String so wie jetzt zusammenbasteln.
PS: Ich habe das Beispiel auf der Lib verwendet um zu starten und nich sehr viel daran verändert.
so wie es aussieht habe ich einen kleinen fehler im baustein wenn der dns_client benötigt wird…
es gibt einen konflikt zwischen dns_client und mysql zugriff so das die daten verfälscht werden.
ich habe dir einen gepatchten baustein online gestellt
den baustein in deiner lib austauschen, testen und mir wieder bescheid geben, ob es nun besser ist.
Besten Dank für Deine Hilfe. Das funktioniert jetzt wie es sollte.
Habe betreffend diesen Baustein noch folgende Fragen:
Wie oft geht wird der Domain abgefragt im Hintergrund, wenn das überhaubt? Oder ist das so gedacht, dass beim schreiben, wenn die IP vom Server geändert hat ein Error kommt?
Welche Ports müssen alle Offen sein, damit alles im Hintergrund läuft. Beim Kunden ist es meinstens so dass die IT alles zu macht und .. . Denke du kennst das Problem sicher auch.
Besten Dank für Deine Bemühungen. Die IT hat die beiden Prots aufgemacht. Leider noch ohne Erfolg. Ich habe nun mit dem Wireshark einen Mitschnitt gemacht und denen geschickt. (Kenne mich nicht wirklich mit Wireshark aus)
Müssen noch andere Port in eine Firewall Umgebung geöffnet werden? Von innen nach aussen sei alles offen. In die andere Richtung, also vom Internet zur SPS sind jetzt nur diese 2 Ports offen.
Leider weiss ich nicht wie gute diese IT ist und für mich ist es Neuland. Denke aber dass einige genau wie ich auch vor diesem Problem mal stehen werden…